Bidvest Payments
Incident Report for PayGate
Resolved
This problem has been resolved.
Bidvest account holders' payments have been functioning normally since 10:58 am.
Posted Apr 15, 2024 - 11:16 SAST
Identified
This problem is ongoing. We are in contact with Bidvest on a resolution.
Posted Apr 15, 2024 - 10:09 SAST
Investigating
Please note that payments made via credit cards to Bidvest account holders have been experiencing issues, this has been escalated.
Posted Apr 15, 2024 - 06:41 SAST
This incident affected: Payments - Card (Bidvest).