Capitec card payments degraded
Incident Report for PayGate
Resolved
The problem with Capitec Issued cards has resolved.
We continue to monitor systems for any change.
Posted Mar 22, 2024 - 18:54 SAST
Identified
Please note that Capitec card payments are currently failing. The matter has been escalated.
Posted Mar 22, 2024 - 18:38 SAST
This incident affected: Payments - Card (Capitec).