Capitec Degraded
Incident Report for PayGate
Resolved
Capitec Pay on SiD and Capitec Issuing on 3d Secure for Credit Card are functioning normally again.
Posted Jul 19, 2024 - 09:50 SAST
Update
Capitec Issuing on 3d Secure has recovered. Capitec Pay is still degraded on SID.
Posted Jul 19, 2024 - 09:37 SAST
Identified
Please note that Capitec Pay on SiD as well as Capitec Issuing on 3d Secure are encountering problems at the moment.
Posted Jul 19, 2024 - 07:33 SAST
This incident affected: Payments - SiD Secure EFT (Capitec) and Payments - Card (Capitec).