Standard Bank on 3d Secure
Incident Report for PayGate
Resolved
This problem has been resolved.
Posted Jul 19, 2024 - 08:22 SAST
Investigating
A problem with Standard Bank-issued cards during 3d Secure has been identified and escalated.
Posted Jul 19, 2024 - 07:50 SAST
This incident affected: Payments - Card (Standard Bank).