Capitec payment problems
Incident Report for PayGate
Resolved
This problem has resolved.
Posted Jul 08, 2024 - 11:31 SAST
Identified
Capitec Issuing on 3d Secure is currently down affecting card issuers.
Capitec Pay for SiD is also affected.
Posted Jul 08, 2024 - 09:30 SAST
This incident affected: Payments - SiD Secure EFT (Capitec) and Payments - Card (Capitec).