3d Secure issues
Incident Report for PayGate
Resolved
This problem has been resolved.
Posted Aug 08, 2024 - 01:25 SAST
Identified
A problem has been identified affecting Bidvest, FnB, and Nedbank acquirers. We are in contact with External Partners to resolve the matter.
Posted Aug 07, 2024 - 21:00 SAST
This incident affected: Payments - Card (Bidvest, FNB, Nedbank).