Processing problems

Incident Report for PayGate

Resolved

This problem has been resolved.
Posted Jul 05, 2024 - 10:45 SAST

Investigating

An intermittent processing difficulty is being investigated currently.
Posted Jul 05, 2024 - 10:00 SAST