Degraded Standard Bank Performance
Incident Report for PayGate
Resolved
This problem has been resolved.
Posted Oct 25, 2023 - 04:30 SAST
Investigating
A problem for transactions involving Standard Bank has been identified and escalated
Posted Oct 25, 2023 - 00:15 SAST
This incident affected: Payments - Card (Standard Bank).